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I. Installation Guide 
 

How to install automatically 

If the Update Product Automatically option is set as True and your computer is connected to the 

internet, the application scans and updates your computer when it starts. You can also use Help > 

Check For Update. This command updates the product automatically to the latest available version. 

 

How to install manually 

1. Download the zip file in the XOR3/Redesign list from the Rapidform website: 

http://www.rapidform.com/softwareupdate 

2. Unzip the zip file in a temporary directory. 

3. Double-click the .exe file and follow the instructions. 

Now, you can run Rapidform XOR and check the version by clicking Help > About. 

 

If you have any questions, please feel free to contact INUS Technology, Inc. 

 

E-mail: support@rapidform.com 

Phone: +82-2-6262-9900 

Fax: +82-2-6262-9999 

http://www.rapidform.com 

 

 

 

 

 

 

 

 

 

 

 

http://www.rapidform.com/softwareupdate
mailto:support@rapidform.com
http://www.rapidform.com/
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II. What‟s New in XOR3 Hotfix3 

1. Enhanced Function 

liveScan 

(1) Support VXelements from Creaform 

Insert > Scanner Direct Control > Creaform Handyscan 3D not only supports VXscan 

but also VXelements. You can directly connect and control Creaform Handyscan 3D if 

VXelements or VXscan is installed. Internally Rapidform XOR will try to find and use 

VXelements first, and if it is not available, it will try to find and use VXscan. 

 

 

 

Note 

This function was missed from the XOR3 Hotfix2 release, so it is officially added in this the 

Hotfix3 version. 
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2. Fixed Bugs 

Surface Body 

(1) Missing faces from Auto Surfacing 

Occasionally the resulting body from the Auto Surfacing function (Insert > Surface > 

Auto Surfacing) produces more missing faces than the previous version. This bug has 

now been fixed. 

 

(2) Auto Surfacing Function Unable to Detect Features  

When you moved the slider for the Feature Detection Level parameter under the Feature 

Following Network option in the Auto Surfacing command, the preview feature was not 

displayed. This bug has now been fixed. 
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III. What‟s New in XOR3 Hotfix2 

1. Enhanced Functions 

File I/O 

(2) Support FARO Scene 4.8 

FARO Scene 4.8 is now supported. You can read the “.fls” file generated from FARO 

Scene version 4.8 by using File > Import command in Rapidform XOR. 

 

 

(3) Support SolidWorks 2010 

The Rapidform Exchange™ kernel has been updated and it is implemented in Rapidform 

XOR. You can now directly import native files (“.sldprt”, “.sldasm”) from SolidWorks 2010. 
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Note 

Rapidform Exchange™ currently supports the native CAD file formats listed in the table 

below. You need to purchase and install a Rapidform Exchange™ license to directly 

import these file formats. 

CAD File Extension Version Supported Comments 

CATIA V4 .model CATIA 4.1.9 to CATIA 4.2.4 - Geometry Only 

CATIA V5 .CATPart, .CATProduct CATIA V5 R2 through R20 - Geometry Only 

- Unsupported non-ASCII 

character in the file name 

Pro/E 

Wildfire 

.prt, .prt.*, .asm, .asm.* Pro/E 16 to Wildfire 5 - Geometry Only 

Siemens 

NX 

.prt Unigraphics 11 to 18 and 

NX1 to NX7 

- Geometry Only 

SolidWorks .sldprt, .sldasm SolidWorks 98 to 2010 - Geometry Only 

 

 

Mesh 

(1) Speed up editing textured mesh 

Rapidform XOR supports multi-thread processing technology for meshes that contains 

textures. The calculation speed on a multi-core CPU is 30-40 percent faster than a single-

core CPU. Multiple cores are utilized when you edit textured meshes by using tools under 

Mesh Tools. 
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liveScan 

(1) Support VXelements from Creaform 

Insert > Scanner Direct Control > Creaform Handyscan 3D not only supports VXscan 

but also VXelements. You can directly connect and control Creaform Handyscan 3D if 

VXelements or VXscan is installed. Internally Rapidform XOR will try to find and use 

VXelements first, and if it is not available, it will try to find and use VXscan. 

 

 

(2) Support Shining Tech 3D scanner under scanner direct control 

Insert > Scanner Direct Control supports 3D scanners from Shining Tech. You can 

directly connect and control Shining Tech‟s 3D scanners through Rapidform XOR. 
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2. List of Fixed Bugs 

General 

(3) Fillet and Helix cause program crash or lock up 

While applying “Fillet” or “Helix” commands, the application could crash or lock up. It was 

caused by a conflict with the web page in the Support tab. This bug has now been fixed. 

 

(4) Excessively bright vertex shading 

Under the following two circumstances excessively bright vertex shading was introduced;  

 If the Point Shader setting was set to “None” and the Normal option was checked 

in the Display tab when displaying a point cloud. 

 If Vertex and Normal were on when displaying a mesh. 

This bug has now been fixed. 

 

Before Fixed Bug 

 

After Fixed Bug 

 

(5) Preview box error in the Clip command 

Depending on the model, the “Clip” command (View > Clip) wrongly generated a preview 

box when choosing the “Inside Box” option. This wrongly aligned the preview box making 

it difficult to clip the model. This bug has now been fixed to align the preview box to the 

X,Y, and Z directions, the same as the global coordinates. 
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(6) Unsuppress makes crash 

When double-clicking a suppressed feature in the Feature tree to edit it, a dialog box 

appeared asking if the user wanted to unsuppress the feature or not. If the “Cancel” button 

was clicked then the application might crash. This error especially happened to Auto 

Surfacing features. This bug has now been fixed. 

 

(7) Change option name in Batch Process 

Some option names under Action When Error Occurs were changed to let users 

understand the options more intuitively. These options are located in a dialog box in File > 

Batch Process > Run. 

 

New Version 

 

Previous Version 

 

(8) Generating normal of “.pcn” file 

When importing “.pcn” files, they would be enhanced by the normal generation algorithm. 

Now normal directions are more accurately calculated than in the previous version. 

 

liveTransfer 

(1) Problem in the liveTransfer To SolidWorks command 

When sending a model to SolidWorks and the surface body had an intersection with a 

target body that was cut by a tool body, sending could fail. This bug has now been fixed. 
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Ref. Geometry 

(1) Reset error on Ref. Geometry preview 

If selecting a region to generate a Ref. Geometry, the previous selection was stacked and 

displayed in the preview. This bug has now been fixed. 

 

(2) Sub-option under fitting Ref. Geometry 

When creating a Ref. Plane, Ref. Vector or Ref. Cone using the “Extract” method from 

the analytic features on a mesh, the sub-option was not activated. Now the “Fix Axis” sub-

option is available. 

 

Scan Data 

(1) Incorrect functioning of the Global And Fine option with Partial region while 

the Align Between Scan Data command is running 

When aligning scan data by using the “Global And Fine” option with regions defined as 

Partial regions while the “Align Between Scan Data” command (Tools > Scan Tools > 

Align Between Scan Data) is running, the following problems could occur: 

- Unable to select poly-vertices when defining a Partial region on the Point Cloud 

- The Error Message, “Selections or parameters are not valid for this operation” 

pops-up when defining a Partial region on the Mesh and then clicking the “Apply” 

button 

- “Region” is displayed on the tool-tip, as one of the selectable entities, even though the 

region cannot be defined as the Partial region 

These bugs have now been fixed. 

 

(2) Incorrect performance of the Undo and Apply functions in the Align 

Between Scan Data command 

 Sometimes the “Apply” function would not perform after the “Apply” and the “Undo” 

functions had been used if the “Align Between Scan Data” command (Tools > Scan 

Tools > Align Between Scan Data) was running. The bug has now been fixed. 
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(3) Crashes in applying triangulations to small-sized scan data 

When applying triangulations to small-sized scan data (smaller than approx. 10mm) by 

using the “Triangulate” command (Tools > Scan Tools > Triangulate) with the “Mesh 

Construction” option enabled, a crash could occur. The bug has now been fixed. 

 

(4) Slow calculation time with the Triangulate command 

When estimating the distance between vertices by clicking the “Estimate” button while the 

“3D Triangulate” option in the “Triangulate” command (Tools > Scan Tools > 

Triangulate) was being used to generate a mesh from point cloud, extremely small 

distance values were estimated as the Distance Criteria and the calculation time was 

much longer than XOR2 SP1. The bug has now been fixed. 

 

(5) Texture problem in the Mesh Buildup Wizard command 

While following the steps in the “Mesh Buildup Wizard” command (Tools > Scan Tools > 

Mesh Buildup Wizard) using scan data, the Textures could disappear at the final step. 

The bug has now been fixed. 

 

(6) Abnormal faces occur in the mesh after the Decimate command is 

performed 

After applying the “Decimate” command (Tools > Mesh Tools > Decimate) to mesh, 

there was a problem that some abnormal faces, such as folded faces and sharp-edge 

faces occurred in the mesh. Many of the abnormal faces occurred when applying the 

command while setting the “High Curvature Area Resolution” option to “Dense”. The 

healing process has been improved and the bug has now been fixed. 

 

(7) Real-Time display of deviation result problem in the Mesh Deviation 

command 

Normally when hovering the mouse cursor on the mesh while the “Mesh Deviation” 

command (Measure > Mesh Deviations) is running, the deviation results are displayed in 

real-time. However, when applying the command to large point clouds the deviation results 

were not being displayed in real-time. The bug has now been fixed. 
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(8) Progress bar stops while the results are previewing in the Merge command 

When clicking the “Preview” button to check the results while using the “Merge” command 

(Tools > Scan Tools > Merge) with the “Mesh Construction” option, the progress bar 

sometimes stopped at 91%. The bug has now been fixed. 

 

Region 

(1) Unstable displaying of region groups after alignment with large translation 

of mesh 

When zooming in on the mesh segmented region groups after applying the “Interactive 

Alignment” command (Tool > Align > Interactive Alignment) to the mesh, the region 

groups could disappear. The bug has now been fixed. 

 

Surface Body 

(1) Problems in Mesh Fit command 

While using the “Mesh Fit” command (Insert > Surface > Mesh Fit) to create fitting 

surface bodies from mesh, errors could occur, such as: 

- If using the “By Allowable Deviation” method, only the preview of the surface 

constructed by minimum control points was displayed at the second stage. 

- If stepping backward and changing parameters, such as Resolution Type and Control 

Point, at the first stage the changes were not applied to the results. 

- If using the “By No. Of Control Point” method, the defined number of control points 

were not applied to the results at the third stage (Iso-Line Density Control). 

These bugs have now been fixed. 

 

Curve 

(1) Extract Feature Curve command doesn‟t work for long range scan data 

When using long range scan data that  has a large file size and many complex features, 

the “Extract Feature Curves” command (Tools > 3D Sketch Entities > Extract Feature 

Curves) didn‟t work. The bug has now been fixed. 
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(2) Convert entity crash 

Converting an edge from a body in 3D sketch mode could cause the application to crash.. 

The bug has now been fixed. 

 

Scanner Direct Control 

(1) Problem in setting Range7 / Range5 Hardware Preference 

A variety of different types of 3D scanners can be chosen under the “Scanner Direct 

Control” section in the “Hardware” tab of the “Preferences” menu (File > Preferences), 

from the “Scanner Direct Control” menu (Insert > Scanner Direct Control) and can 

directly be controlled through XOR3. However, the “Konica Minolta range7 / range 5” 

menu under the “Scanner Direct Control” section in the “Preferences” was not visible. 

The bug has now been fixed. (Rapidform XOR3 64bit version only) 

 

(2) Crash in using Z Corporation Zscanner (I) 

The program could crash if the last item under the Scan List in the control panel was 

selected and removed while the “Z Corporation Zscanner” command (Insert > Scanner 

Direct Control > Z Corporation Zscanner) was running. The bug has now been fixed. 

 

(3) Crash in using Z Corporation Zscanner (II)  

The program could crash if the “Center Volume” button was clicked without any registered 

scan data in the Scan tab while the “Z Corporation Zscanner” command (Insert > 

Scanner Direct Control > Z Corporation Zscanner) was running. The control panel has 

now been improved so that the “Center Volume” button is set to be inactive when scan 

data does not exist.   

 

(4) Crash in using Creaform Handyscan 3D 

The program could crash if the “Center Volume” button was clicked without any registered 

scan data in the Scan tab while the “Creaform Handyscan 3D” command (Insert > 

Scanner Direct Control > Creaform Handyscan 3D) was running. The control panel has 

now been improved so that the “Center Volume” button is set to be inactive when scan 

data does not exist. 
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(5) Hold Connection problem in the liveScan command 

If closing the “liveScan” command (Insert > liveScan) with the “Hold Connection” 

checked, the program could show connected device still attempting to be connected. The 

bug has now been fixed. 

 

Add-Ins 

(1) Register Target command is disabled when there are no point clouds or meshes 

The “Register Target” command (Add-Ins > Register Target) can be used for point 

clouds or meshes in the Model Tree as well as for scan data in a user defined folder. 

However, the command was disabled when no point clouds or meshes were present in the 

program. The command has now been improved so that it is always activated regardless 

whether the scan data is present in the program or not.  

 

Measure 

(1) Problem in the Distance command 

 When using the “Distance” command (Measure > Distance), problems could occur such 

as: 

- When measuring the distance between bodies, only the “Auto” method was available. 

- Even if the Method was set to “Along Face”, measuring the distance between bodies 

and meshes far away from each other was still possible. 

- After measuring the distance on the body with the “Along Face” method and then 

transforming the body by using the “Transform Body” command (Insert > Modeling 

Feature > Transform Body), some strange edges could be created at the measured 

position. 

These bugs have now been fixed 

 

License 

(1) Wrong license message appears for expired licenses 

A wrong license message appeared if the Activation License or Maintenance license is 

expired. It has been changed so that the appropriate message appears. 
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(2) Wrong expiration warning message appears for expired Maintenance 

A wrong expiration warning message appeared if the Maintenance license has expired. It 

has been changed so that the correct expiration warning message - “Your maintenance 

agreement has been expired” appears. 
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IV. What‟s New in XOR3 Hotfix1 

1. Enhanced Functions 

User Interface 

(1) New Online Support Page 

Online Support Page in the Support tab 

has been changed. It allows you to 

search for information faster and easier. 

The support tab provides you with helpful 

information such as the latest tutorials, 

FAQs, and technical tips. Also, you can 

send us your feedback for Rapidform 

products. Your feedback will be used to 

enhance and improve performance of 

Rapidform products. You can also 

access the Online Support Page via 

your web browser with: http://support.rapidform.com/home  

 

(2) Change name displayed in Menu or Command Dialog from “UGS NX” to 

“Siemens NX”  

Name displayed in Menu or Command Dialog has been changed from “UGS NX” to 

“Siemens NX”. 

 

File I/O 

(1) Import new scan file 

This application supports three new scan data file types: 

- Import of FARO FLS 4.7 version is supported. 

- Import of Breuckmann CTR file format is supported. 

- Import of Imetric I3D file format is supported. 

http://support.rapidform.com/home
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Display 

(1) Enhanced Point Shader option 

Point Shader options for point clouds are now available for meshes as well. The option is 

also available for previewing point clouds in liveScan™. 

Now all data types can be viewed with similar options. With various shading methods, you 

can easily and view the scan data effectively. 

  

< Mesh Shader: Vertex>               < Normal Display: On > 

  

< Depth Point Shading >               < X-Ray Point Shading > 

Note 

When the Point Shader option is applied to the mesh, it can be performed while the mesh 

is set to the Vertex in Mesh Shader. 
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Ref.Geometry 

(1) Display Position and Direction (or Normal) with previewing Ref. Geometry 

When a Ref. Vector or Ref. Plane is created by the By Definition method, the defined 

Position and Direction (or Normal) are now displayed with the model in Model View. You 

can recognize the position and the direction of Ref. Geometry more easily. 

  

< Previous Version >                 < Current Version > 

 

(2) Create Ref. Point by importing file 

When an ASCII file is imported as Ref. Points, you can now easily set one of columns in 

the entity list then object name by choosing the Name option in ASCII Converter. The 

entity names will be preserved as feature names. 
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Scanner Direct Control 

(1) Support Konica Minolta RANGE5 / RANGE7 

You can now control Konica Minolta RANGE7 as well as RANGE5 scanner by clicking 

Konica Minolta RANGE5 / RANGE7 in Scanner Direct Control menus. 

It can be used in the 64-bit version only. 

 

(2) Newly supported devices on 64-bit 

The three following liveScan™ devices are now supported in the 64-bit version: 

- [NDI] ScanTRAK/OPTOTRAK  (http://www.ndigital.com)  

- [Perceptron] ScanWorks  (http://www.perceptron.com) 

- [LDI] SLP  (http://www.laserdesign.com)  

 

(3) Newly supported scanner interface 

New devices have been added to the software: 

- [Nikon Metrology] Handheld (32-bit, 64–bit) in liveScan™  

(http://www.nikonmetrology.com/)  

- KODEN OCM-A (32-bit)  (http://www.koden-electronics.co.jp/eng/)  

- Shining Tech (32-bit)  (http://shiningtech.diytrade.com)  

- 3DD (3D Digital Corp.) (32-bit)  (http://www.3ddigitalcorp.com)  

 

(4) Configure FaroArm hardware setting 

When using a FaroArm/ScanArm in liveScan™, you 

can now access the Hardware Configuration dialog 

by clicking the Calibration button. 

Clicking Calibration shows a prompt that asks users 

to choose between hardware calibration process and 

hardware configuration settings. 

 

http://www.ndigital.com/
http://www.perceptron.com/
http://www.laserdesign.com/
http://www.nikonmetrology.com/
http://www.koden-electronics.co.jp/eng/
http://shiningtech.diytrade.com/
http://www.3ddigitalcorp.com/
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(5) Enhanced Grid Sampling in liveScan 

Grid sampling calculation has been enhanced. The data scanned by a scanner is 

processed by grid sampling when the Sampling option in the Data Process tab of the 

Scanner Option window is set to Grid. Now, you can get smoother and more accurate 

scan data with lower noise and distorted boundaries. 
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2. List of Fixed Bugs 

General 

(1) The warning message displayed for specifying the batch process log file 

location 

When you executed the Run command in Batch Process and browsed the batch process 

log file location in the Run Batch Process dialog box by clicking the File Path browse 

button, a warning message which had a button withouhandy text was displayed. The 

button text is Retry and the bug has now been fixed. 

 

(2) XOS3 Crash when XOR3 has been installed 

When you started XOS3 with a user level while XOR3 was running, XOS3 crash occurred. 

The bug has now been fixed. If the OS is Vista or Windows 7 and you are trying to use 

both of XOR3 and XOS3, “Run As Administrator” message will appear when you right-

click the shortcut icon or the exe file. 

Note: You can run both applications by accessing via Administrator user level.  

 

(3) Graphic problem 

When the graphic card was NVIDIA Quadro FX series, sometimes the triangle-shape 

mesh was abnormally displayed. The bug has now been fixed.  

 

(4) Thumbnail order in Mesh Buildup Wizard 

When you started Mesh Buildup Wizard with a set of scan data, sometimes the order of 

the scan data was mixed in the Thumbnail View. The bug has now been fixed. Now the 

scan data is displayed in the Thumbnail View in order as in the Model Tree. 
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File I/O 

(1) Unavailable to use the “Include Vertex normal” option for ASC format  

When you imported an asc file, the Include Vertex Normal option in the Import dialog 

box was disabled. The bug has now been fixed. 

In addition, even if the vertex normal and color were designated in Ascii Converter when 

the Include Vertex Normal and Include Texture options in the Import dialog box were off, 

the designated vertex normal and color were not applied. Now, if the vertex normal and 

color were designated in Ascii Converter, the settings of the options in the Import dialog 

box are ignored. 

 

(2) “Not enough memory” error while importing an RVM file 

When you imported a rvm file, there was a chance encounttering an error stating “Not 

enough memory”. The bug has now been fixed. 

 

(3) Wrong coordinates of measured-type point cloud in MDL file 

When you exported planar or spherical point could as the mdl file format and loaded the 

mdl file, the coordinates of the point cloud were wrong. The bug has now been fixed.  

 

(4) Mesh entity with no vertex in some imported WRL files 

When you imported some wrl files, a mesh entity with no vertex was created on the model 

tree. The bug has now been fixed.  

 

Scan Data  

(1) Incorrect functioning of Rotate and Translate option of Transform Scan Data  

In Scan Tools> Transform Scan Data, when you selected Rotate and Translate method 

and checked the Use Local Coordinate option, the manipulator did not move to the 

center of the local coordinate. Now it has been fixed. When you check the Use Local 

Coordinate option, the manipulator moves to the center of the local coordinate. In reverse, 

when you uncheck the Use Local Coordinate option, the manipulator moves to the center 

of the mesh. If you check the Use Local Coordinate option but there is nothing in the 

select set, the manipulator moves to the origin of the global coordinate.  
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(2) Unavailable to perform „Undo‟ in the middle of aligning scan data 

When you clicked Break button in the middle of aligning scan data using Align Between 

Scan Data command, the scan data did not stop and you could not perform Undo. The 

bug has now been fixed.  

 

(3) „Auto Select‟ button operation problem in Best-Fit stage of Mesh Buildup 

Wizard 

When you clicked Auto Select button in Best-Fit Align step of Mesh Buildup Wizard, the 

button did not work. The bug has now been fixed.  

 

(4) Difference between the result of Region and Mesh created using Average 

Meshes command 

When you created regions from the mesh using region segmentation and created mesh 

using Average Meshes command, the created mesh was different from the region. The 

bug has now been fixed.  

 

(5) Wrong operation of selecting vertex on the point cloud 

When you selected vertexes on the point cloud using a paint brush, two operations did not 

correctively function; first, unselect by pressing Ctrl key was unavailable, and second, 

wrong part was selected in Walkthrough mode using the mouse pointer. The bug has now 

been fixed.  

 

(6) Lost vertex normal information in the XRL file  

When you imported an XPC file, created vertex normal in the point cloud by executing 

Tools > Scan Tools > Normal Information Manager, and saved the result in xrl file 

format, the vertex normal information of the point cloud was lost from the xrl file. The bug 

has now been fixed.  
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(7) Memory leakage 

When you performed Decimate Meshes command and moved the mouse pointer on the 

shells, the memory usage was continuously increased. This is a kind of memory leakage. 

The bug has now been fixed.  

 

(8) Crash in 2D triangulate 

In Triangulate (poly-vertices) for several meshes, when you clicked the scan direction 

arrows to correct the scan directions, some point clouds were selected on the model tree. 

In this case, when you clicked Apply button, an error occurred. At this time, the selected 

point clouds were registered as a separate point cloud.  

Also, when you clicked Scan Direction magic wand one more time after the error, the 

crash occurred. The bug has now been fixed. 

 

(9) Crash in copying the suppressed mesh 

When you selected a mesh data which had been imported and suppressed and pressed 

the Ctrl + C keys to copy it, a crash occurred. The bug has now been fixed. 

 

Region 

(1) Slow region drawing time 

When you load a mesh data which contains more than 4 million points to create regions, 

region drawing speed was slower than that of XOR2. The bug has now been fixed. 

 

Ref. Geometry 

(1) Ref. Geometry fitting without Max Point Number option 

When a Ref. Geometry was created by fitting using the vertex or poly-face of mesh data, 

the Max Point Number option specified in Preference was not applied to the fitting. The 

bug has now been fixed.  
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Scanner Direct Control 

(1) Not intuitive UI buttons in liveScan™  

When you executed liveScan™, the Scanner Options window was displayed. However, it 

was difficult to intuitively see whether the Camera and Zoom buttons in the General tab 

were pushed or not and how these buttons worked. The bug has now been fixed. 

 

(2) Problems in HW interface commands corresponding to user account 

execution 

When you executed Creaform, ZScan or Range7 commands, some problems occurred 

due to the user authority level. The bug has now been fixed. 
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V. What‟s New in XOR3 

1. New Functions 

liveTransfer™ 

Benefits of 

liveTransfer™ 

 You can transfer 

parametric models as 

well as modeling 

history to your CAD 

system from Rapidform 

XOR. 

 There is no need to 

build model up again in 

your CAD system. 

 You can reduce time 

consuming job, 

eventually saving time 

and money. 

 

liveTransfer(TM) To is in real-time and feature-by-feature CAD translation 

compatibility command. During the modeling process in Rapidform XOR, the 

application flags operations that will not translate smoothly into CAD program and 

also suggests alternative techniques. And you can directly send a model with its 

entire modeling history to other CAD software afterward. 

Now, liveTransfer™ supports AutoCAD liveTransfer as well. 

 

Functions Details 

  

 

The following table indicates which CAD program liveTransfer™ supports 

CAD Program Supported Version Newly Supported Version 

CATIA  
CATIA V4 (CATIA 4.1.9) 

CATIA V5 (CATIA V5 R6) 

SolidWorks 

SolidWorks 2006 

SolidWorks 2007 

SolidWorks 2008 

SolidWorks 2009 

SolidWorks 2010 

UGS NX 
UGS NX4 

UGS NX5 

UGS NX6 

UGS NX7  

Pro/E Wildfire 
Pro/E Wildfire 3.0 

Pro/E Wildfire 4.0 
Pro/E Wildfire 5.0 

AutoCAD  

AutoCAD 2007 

AutoCAD 2008 

AutoCAD 2009 

AutoCAD 2010 

AutoCAD 2011 
 

Supports new version 

of CAD program 
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Batch Process 

Benefits of  

Batch Process 

 You can easily design 

batch process in Batch 

Process Designer. 

 You can share the 

defined batch process 

among other users. 

 You can reduce time 

consuming job, 

eventually saving time 

and money. 

 It is very useful for users 

who frequently perform 

a set of operations on 

the scan data and who 

handle a large size scan 

data. 

 

Batch Process allows you to execute a set of batch jobs without manual 

intervention. You can easily design batch jobs by dragging & dropping and you 

can apply these jobs to multiple sets of scan data just in one-click. After 

performing batch process, you will get a report and a final result as defined. 

You can also export or import the designed batch jobs. 

The application provides several preset template batch jobs. You can also easily 

use these batch jobs for your scan data.  

 

Function Details 

The following table illustrates which batch jobs can be designed in Batch Process 

Designer.  

Tools Command 

Scan Tools  Align Between Scan Data 

 Triangulate 

 Merge 

 Combine 

 Transform 

Mesh Tools 

 Global Remesh 

 Optimize Mesh 

 Fill Holes 

 Decimate 

 Subdivide 

 Enhance Shape 

 Healing Wizard 

 Sew Boundary 

 Rewrap 

 Smooth 

Surface Tools  Auto Surfacing 

Point Cloud 

Tools 

 Smooth 

 Sampling 

 Filter Noisy Point 

File  File Export 

 

 

 

Batch Process allows you to apply batch process to 

multiple sets of scan data even to the scan data that are 

organized by folder groups 

Toolbar for Batch jobs management 

 

Batch Jobs List 

 

Defined Batch Jobs 
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Multi-Core Processor Support 

Benefits of  

Multi-Core 

Processor 

 It allows greatly 

reducing calculation 

time and improving 

performance of your 

operations. 

 

 

Multi-core processor is a processing system that has two or more independent 

cores. Rapidform XOR has supported single and dual-core processor and now 

supports Multi-core processor as well in some commands. It improves 

performance of your operations higher than that of a single and dual-core 

processor. 

 

Function Details 

Rapidform XOR now uses multi-core processor to improve performance of 

operation especially when you align large size scan data by using Global 

Alignment method, check results with Accuracy Analyzer™, extract design intent 

from a scan data by using Redesign Assistant™ and extract Ref.Geometries from 

a scan data by fitting operation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Multi-Core Processing 
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Large Point Cloud Handling 

Benefits of  

Large Point Cloud 

Handling 

 A new out-of –core 

massive point cloud 

engine handles huge 

size scan data 

 So now, you can much 

more easily handle 

massive scan data 

generated by long range 

3D Scanners. 

 Real-time rendering 

of hundreds of 

millions point cloud  

 Allows you to design 

geometric features in 

detail based on the 

massive scan data. 

  

Rapidform XOR greatly improves capability of massive scan data handling 

process and visualization. It allows real-time rendering of hundreds of millions 

point cloud. Now you can import and easily handle the massive scan data 

generated by long range 3D scanners and design geometric features in detail 

based on the scan data. 

You can keep running your operation without compromising performance. 

 

Function Details 

 Import Massive Size Point Cloud 

Now you can easily import massive point cloud into the application even if it is 

out-of-core massive data. 

When the massive point cloud is imported into the application, it is 

automatically stored to the cache folder in your system in divides and then 

efficiently loaded onto the application within capability of physical memory 

when some operation is performed. 

 

 

 Real-Time Visualization of Massive Point Cloud 

 Real-Time Rendering of Hundreds of Millions Point Cloud 

Rapidform XOR efficiently displays point cloud in 

an appropriate density so that you can recognize 

feature shape of model according to your current 

view point 

And it also maintains fast rendering time with the 

Auto Frame Rate function so that you can easily 

have a look at the model.  
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 New Shading Methods 

Point Shader option has been newly added in the Display Tab. 

It performs for point cloud with various shading methods to effectively see 

and analyze the complex data. 

 

 

 

 

 

 

 

 

 

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 New Viewing Method 

New viewing method called „Walk-Through‟ has been added as one of the 

methods in the View menu. 

You usually have a look in the model by rotating, panning, and zooming 

with the default viewing mode. So, you only can see outside of the model.  

Now this Walk-through command allows you to move your viewpoint as 

you walk through in the model and check the inside of model in detail.  

None: This is a default shading method. Point cloud is shaded with the current light condition. 

Depth: It makes closer points brighter in the view direction and further points darker. 

X-Ray: it makes closer points and further points transparent in the view direction and displays the 

interesting area to clearly see the inside area of scan data. 

Height: It displays point cloud with different color map according to the height of the Z direction. 

Depth Point Shading 

Height Point Shading X-Ray Point Shading 

Default (None) 
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 “Fully Editable” Massive Point Cloud 

Rapidform XOR fully provides not only visualization for the massive and 

complex point cloud but also point cloud editing functionalities. 

 

 Select and Edit Point Cloud 

Now you can easily select the interested area on point cloud and edit 

them by using the various selection tools.  

If the point cloud have some noises or you have picked up some floor, 

side wall, or ceiling points while scanning, then you can easily select them 

only by using Extend To Similar or Extend To Sudden Change selection 

tools and remove those unwanted areas. And you can also easily select 

the interested features only by using Paint Brush selection tool without 

interference with the other complicate feature shapes and then copy, cut, 

or paste as new point cloud.  
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 Optimized Point Cloud Tools for Massive Point Cloud 

All commands in the Point Cloud Tools such as Sampling, Filter Noise, 

Smooth, etc. are optimized for massive point cloud. Now you can easily 

optimize and edit massive point cloud with by using those commands. 

Particularly, when you filter noises from the point cloud, you can quickly 

filter the outlier of point cloud with Box Volume or Scanner Range by 

using Filter Outlier Regions option which has been newly added in the 

Filter Noise command. 

. 

 

 

 

 

 

 

 

 

 

 

 

And moreover, you can much more 

easily create a mesh from point 

cloud by using Construct Mesh 

command which has been newly 

added as one of Point Cloud Tools. 

You can also directly use this 

command in the pop-up menu. 

 

 Unlimited Capacity of Mesh Construction 

There is no limit to construct mesh from massive point cloud generated by 

long range 3D scanners. You can easily select the entire point cloud or 

interested partial area of the point cloud and then you can construct a 

single mesh or several individual meshes from them by using Construct 

Mesh command. You can also directly construct a mesh or meshes from 

the selected area of point cloud by choosing the Construct Mesh in the 

pop-up menu. 

Filter Outlier Regions with Box Volume Filter Outlier Regions with Scanner Range 
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 Sketching and Feature Modeling from Point Cloud 

Now you can much more easily extract various design intent from massive 

point cloud and quickly design feature shapes from the point cloud. 

You can draw sketch profiles based on the silhouette of point cloud as well as 

on the point section by fitting or snapping the section points. 

  

 

And if pipe shapes are in the point cloud, you can easily and quickly complete 

pipe modeling by using Pipe Wizard which has been newly added as one of 

the Modeling Wizards.  
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 New File Formats for Massive Point Cloud 

Optimized file format in accordance with new point cloud handling process has 

been newly added as new file format called rapidform eXtreme Point Cloud 

(„*.xpc‟). 

With the new version of Rapidform XOR file format („*.xrl‟) which has been 

upgraded up to 3.0 and the new file format will be standard for efficiently 

handling massive point cloud.  

Addtionally, if you want to publish huge 

size point cloud as Point Stream or ICF 

file format for sharing through the Web, 

now you can adjust the size of data by 

using sampling ratio as desired. 
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Mesh Buildup Wizard Enhancement 

Benefits of  

Mesh Buildup 

Wizard 

 It can quickly and 

automatically generate 

watertight mesh from 

raw scan data. 

 

Mesh Buildup Wizard is automated tool for creating watertight mesh from raw 

scan data. Now this wizard-style interface has been greatly enhanced with five 

different stages such as Data Preparation, Data Editing, Data Pre-Aligning, Best-

Fit Aligning, and Data Merging. It provides a fully optimized mesh buildup process 

according to the scanner type of target scan data. You can much more easily 

create a watertight mesh from raw scan data and also cope with any scanner type 

with newly enhanced Mesh Buildup Wizard. 

 

Function Details 

 Data Preparation 

In the first stage, you can choose a scanner type which you have used to scan 

a target object. It provides different parameters and options during the process 

according to your definition of scanner type. 

 

 Data Editing 

In the second stage, it helps you to easily edit scan data. If the scan data have 

some noises or you have picked up some floor poly-faces while scanning 

object, then you can easily remove those unwanted areas with various editing 

tools.  

 

 Data Pre-Aligning 

In the third stage, it allows you to easily align scan data no matter where the 

scan data are. They are automatically aligned with each other by using the 

geometric shape information. And you can also manually align the scan data 

by picking several corresponding points on the scan data.  

 

 Best-Fit Aligning 

In the fourth stage, it allows you to accurately align scan data with Best-Fit 

alignment algorism. 

 

 Data Merging 

Finally, you can merge the aligned scan data into a single mesh and then you 

will get a watertight mesh.  
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Auto Surfacing Enhancement 

Benefits of  

Auto Surfacing 

 It can quickly and 

automatically generate 

high quality surfaces no 

matter how complex the 

target mesh is. 

 You can quickly get a 

result. You can reduce 

time consuming job, 

eventually saving time 

and money. 

 

Auto Surfacing that allows you to automatically generate freeform surface patches 

from a mesh has been greatly enhanced.  

The name of the existing method has been changed to „Evenly Distributed 

Network‟ and now the other auto surfacing method which is called „Feature 

Following Network‟ has been newly added in the Auto Surfacing. It allows you to 

automatically construct surface patches on the mesh considering its feature shape 

and It also can effectively construct surface patches which can cover the entire 

mesh with much less surface patches even if some holes are in the mesh. 

Now, you can generate a freeform surface patches having evenly distributed 

network as well as with a patch network following the feature shape on the mesh. 

 

Function Details 

 Evenly Distributed Network option allows you to automatically construct 

evenly distributed surface patches which can cover the entire mesh. You can 

manually define the target number of surface patches and then the application 

automatically constructs surface patches on the mesh as defined.  

 Feature Following Network option allows you to automatically construct 

surface patches following feature shape of mesh. Since it‟s automatic, you 

don‟t need to know how to construct curve network on the mesh following its 

feature shape and how many surface patches are needed to cover over the 

entire mesh.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can construct surface patch network on 

the target mesh following its feature shape.  

You can construct evenly distributed 

surface patch network on the target mesh.  
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Mesh Fit Enhancement 

Benefits of  

Mesh Fit 

 No need to create 

profiles for surface 

generation. Just with 

one-click on the target 

regions, you extract 

design intents and get a 

high quality surface 

body. 

 It is very useful for users 

who want to quickly 

extract design intents 

from complex freeform 

regions of a mesh. 

 

Mesh Fit allows fitting surface generation on feature regions or selected regions of 

a mesh no matter how complex the target regions are. 

In sub-stages you can freely control a flow of fitting surface body and its Iso-Lines. 

This option is now added in the Mesh Fit command.  

Now, you can get a higher quality surface body as well as an accurate result with 

less number of control points. 

 

Function Details 

 Newly Added Second Stage 

You can freely adjust a flow of fitting 

surface body by controlling the control net 

and the position of control points. 

 

 

  

 

 

 

 

 

 

 Newly Added Third Stage 

You can freely control the position of Iso-

Lines and you can also add or remove them 

as well. 

 

 

 

 

 

 

 

 

 

 

 

Control Net 

V Direction 

U Direction 
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Auto Curve Network Generation 

Benefits of  

Auto Curve Network 

Generation 

 You can easily and 

quickly construct curve 

network on a mesh even 

though feature shapes 

of the mesh are 

complex. 

 You can generate a 

freeform surface body 

on the mesh using the 

extracted feature 

curves. 

 You can reduce time 

consuming job, 

eventually saving time 

and money. 

 

Create Curve Network has been newly added as one of the 3D Mesh Sketch 

Entities. 

It allows you to automatically construct feature curve network which can cover the 

entire feature shape of mesh. 

The generated feature curves can be edited same just like the other curves. 

 

Function Details 

It is performed in the 3D Mesh Sketch mode only. 

You can easily construct feature curves on a mesh by controlling Feature 

Detection Level option. 

  

After an initial curve network is generated, you can also easily modify the feature 

curves in the second stage by using Deform, Merge, Remove, Split, and Detach 

And Move Tools. 

  

 

 

Extracted Feature Curves 

Deform Curves 

Remove and Merge Curve Loops 

Split Curve Loop 

Detach And Move Curve 
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Mesh Averaging 

Benefits of  

Mesh Averaging 

 You can easily generate 

a master feature from a 

set of several scanned 

features. 

 It is very useful for users 

who want to create a 

master model from 

handicraft models or 

several sets of scanned 

model. 

 

Mesh Averaging has been newly added as one of the Scan Tools. 

It allows you to generate an averaged and optimized master feature shape from a 

set of several scanned feature shapes. And it also allows you to extract a 

reasonable feature shape if you have patterned scan feature shapes. 

 

Function Details 

When you have a model which has patterned feature shapes or a set of several 

scanned models, this function can be used for creating a master feature shape or 

a master model from them. 

Mesh Averaging consists of two stages as described below. 

 

 First Stage – Define Targets 

You can define target features in the first stage.  

If the model has patterned features (Circular or Linear), the application 

automatically detects the position of features and then intelligently 

compensates its positions for averaging. 

 

 Second Stage – Check Deviation 

You can check deviation between an averaged 

feature and the selected target features in the 

second stage. It allows you to qualify target 

features from the list to get a more reasonable 

result. 

 

 

 

 

 

 

 

 

 

 

 

 

 

It allows you to expect 

how the result is accurate 

by deviation information.  

Target Features 
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Sweep, Extrusion, Revolution Wizard  

Benefits of  

Sweep, Extrusion, 

Revolution Wizard 

 No need to analyze 

feature shapes to 

extract feature 

information and model a 

surface or solid body. 

You can easily complete 

modeling jobs as you 

want using these 

wizards.  

 You can reduce time 

consuming job, 

eventually saving time 

and money. 

  

Sweep, Extrusion, Revolution Wizard has been newly added in the Modeling 

Wizard. They help you to easily model a surface/solid body from a mesh.  

These wizards intelligently analyze features from a mesh and automatically 

extract feature information such as feature profiles, axis, and path, etc. 

It enables you to quickly complete modeling jobs which you have to do through 

several steps. After a model is completely designed, you can edit the modeled 

surface/solid body whenever you want. 

 

Function Details 

 Sweep Wizard - enables you to easily create a sweep feature using feature 

profiles and sweep path. 

 Extrusion Wizard - enables you to easily create an extrusion feature using 

feature profiles and extrusion direction. 

 Revolution Wizard - enables you to easily create a revolving feature using 

feature profiles and rotation axis. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Sweep Wizard  

Revolution Wizard  

Extrusion Wizard  
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Pipe Wizard 

Benefits of  

Pipe Wizard 

 No need to analyze 

features to extract its 

information and model a 

surface or solid body. 

You can easily complete 

pipe modeling as you 

want using this wizard. 

 

 

 

 

 

 

 

 

 

 

 It is particularly useful 

for users who want to 

create a surface or solid 

body from a pipe model. 

 If you have data which 

is a scanned industrial 

plant and it is difficult to 

extract features 

because of complicated 

pipe lines, this wizard 

helps you to quickly 

complete pipe modeling.  

 You can reduce time 

consuming job, 

eventually saving time 

and money. 

Pipe Wizard has been newly added as one of the Modeling Wizards. 

It helps you to model a surface or solid pipes from a mesh or a point cloud. This 

wizard intelligently analyzes features from a mesh and automatically extracts 

feature information such as pipe radius and path. 

It enables you to quickly complete modeling jobs which you have to do through 

several steps. And you can edit the modeled body whenever you want. 

 

Function Details 

Pipe Wizard consists of three stages. In the first 

stage, you can easily select pipe shapes as target 

features even though many complicate pipe features 

are in the data. In the second stage, you can check 

the previewed result and then define remaining 

bodies. In the final stage, the feature information in 

the extracted pipe shapes are previewed on the 

separated multiple viewports and then you can 

easily edit the parameters of the pipe feature shapes 

at the same time.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Separated Multiple Viewports 

Extracted Pipe path Extracted Pipe Diameter 



 

 Rapidform XOR3 – What’s New  35 

Add Texture 

Benefits of  

Add Texture 

 It enables a mesh model 

to be used for real 

simulation, 3D gallery, 

or animation. 

 If you have a rapid 

prototyping machine, it 

also allows you to get a 

result like a real object 

with texture images. 

 It is very useful for users 

who want to check an 

object in the 3D space 

before the prototype is 

produced. 

 

 

Add Texture has been newly added as one of the Texture Tools. 

It allows you to import a 2D texture image and attach it onto the target mesh. Now, 

you can realistically display a mesh model with a texture image on the Model View 

and export the model including the texture image. 

 

Function Details 

You can easily import a 2D texture image no matter how big the size of the image 

is. The imported 2D texture image automatically pops up on the Texture View and 

then you can just define corresponding points between the imported 2D texture 

image and the target mesh. 

The applied 2D texture image will be mapped according to your definition by 

expanding onto the target mesh. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Corresponding 

Points  

Model View  

Imported 2D Texture Image  
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Match Color 

Benefits of  

Match Color 

 If you have a set of scan 

data which has different 

color information, it 

allows you to 

compensate the color 

information between the 

scan data. 

 It is very useful for users 

who want to create a full 

3D model with color 

information from a set of 

scan data which are 

scanned in different 

scanning environments. 

 

Match Color has been newly added as one of the Texture Tools.  

When an object is scanned with its color information in different scanning 

directions, the scan data may have different color information according to the 

scanning environments such as light, color temperature, and brightness, etc.  

Match Color allows you to easily compensate the color information between the 

scan data. 

 

Function Details 

Before compensating color information between scan data, alignment is required 

to apply Match Color command. 

If you already have aligned scan data, you can easily compensate the color 

information between them by using Choose Among Candidates option and Match 

Color Based On Reference option. 

 

Choose Among Candidates option 

recommends you several compensated 

color candidates and allows you to easily 

choose appropriate color information for the 

model. 

 

Match Color Based On Reference option allows you to compensate color 

information of the target scan data based on the color information of the reference 

scan data.  

 

  

 

 

 

 

 

 

 

 

 

 

 

Target Object  

Reference Object  
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Viewpoint Management 

Benefits of  

Viewpoint 

Management 

 It is very useful for users 

who want to manage 

viewpoints for creating 

the modeling report. 

 

Viewpoint Management has been newly added as one of the management panels. 

You can manage position and orientation of a model as you want to see by 

capturing viewpoint. 

 

Function Details 

You can easily add a current viewpoint of a model and remove as well. 

The added viewpoints can be managed in the Viewpoint panel. 

Anytime, if you want to set the position and the orientation of the model by using 

the added viewpoints, just click the captured viewpoint in the Viewpoint list. The 

model will be displayed by your set viewpoint in the Model View.  

 

 

 

 

 

 

 

Model View 

Viewpoint Management Panel 

Model In Viewpoint 

① Add Viewpoint: Add a new viewpoint to capture the current view state 

② Apply Viewpoint: Change the viewpoint to the selected viewpoint 

③ Show Only Selected Viewpoint: Change the visibility of entities to the selected viewpoint 

④ Reassign Viewpoint: Reassign the selected viewpoint from current view state 

⑤ Delete Viewpoint: Delete the selected viewpoint 

⑥ Zoom: Zoom to the viewpoint image 

⑦ Export Viewpoint: Export the selected viewpoint to image file 
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Flatten and Deform Mesh 

Benefits of  

Flatten and Deform 

Mesh 

 When a scan object has 

been extremely 

deformed, it helps you 

to reconstruct the 

scanned data as it was 

originally designed. 

 It is very useful for users 

who want to redesign 

shape from extremely 

deformed scan data.  

Flatten and Deform Mesh in which you can deform the shape of a mesh has been 

newly added as one of the Add-In commands. 

If a scan object has been twisted or bended because of time, environment, and 

internal / external force, etc., it is difficult to extract correct design intents for the 

reverse modeling process. 

Flatten and Deform Mesh Add-In allows you to easily deform the scanned data as 

it was originally designed. 

 

Function Details 

Flatten/Deform command provides three 

different methods such as Flatten, Deform, 

and Flexible Registration. With these three 

methods, you can easily deform mesh as 

desired. 

 

 

Flatten 

Flattens a bent area and preserve 

features on the bent area. 

 

Deform 

Deforms a flat area to a desired 

shape and preserve features on 

the area. 

 

 

 

Flexible 

Registration 

Applies flatten first and then 

deform target area. During the 

process, features on the area will 

be preserved. 
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2. Enhanced or Changed Functions 

User Interface 

(1) Selection Filter 

Now, you can define only certain specific entities that you want to select in the Model 

View by selecting entity type in the Selection Filter as well as in the Pop-up menu. 

 

 

(2) Enhanced Display Tab 

Point Shader option has been newly added in the Display Tab. 

It performs for point cloud with various shading methods to effectively see the scan data. 

 

 

 

 

(3) Newly Added Transparent Background option 

An option which allows you to set transparent background in the captured image has 

been newly added in the Capture Screen command. 

None: This is a default shading method. Point cloud is shaded with the 

current light condition. 

Depth: It makes closer points brighter in the view direction and further 

points darker. 

X-Ray: it makes closer points and further points transparent in the view 

direction and displays the interesting area to clearly see the inside area 

of scan data. 

Height: It displays point cloud with different color map according to the 

height of the Z direction. 
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(4) Captured Image Management 

Now, you can easily change the order of captured images by drag & drop in the Image 

Folder. 

 

 

(5) Enlarge / Shrink Selection 

Now, you can apply Select > Enlarge / Shrink 

command to the pre-defined feature regions as 

well. You can easily select adjacent regions by 

enlarging or shrinking from seed region. 

 

 

 

(6) Interactive Alignment 

Interactive Alignment has been greatly enhanced. Selectable entities have been 

increased and now, the application automatically and intelligently recognizes alignment 

datums which can be extracted from selected entities. For example, even if you just 

select 3 points, the application automatically recognizes the selected points as a datum 

plane for alignment. 

 

(7) Enhanced Preferences 

Previously, „0%‟ was not allowed to input in the Outlier For Allowable Deviation (%). 

But, now you can input a value between „0%‟ and „100%‟ as you want. If you input „0%‟ in 

the Outlier For Allowable Deviation (%), the application uses the entire scanned mesh for 

fitting. 
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(8) Enhanced Console View 

You can check what operations have been performed in 

the Console View and now you can also check in detail 

how the statistical results are computed after you apply 

aligning between scan data with the Global And Fine 

option. 

 

 

 

 

 

 

 

 

 

(9) Enhanced Properties 

Now, you can directly copy values from the Properties panel by clicking „Ctrl + C‟ key and 

paste it on notepad or Microsoft Office Excel or anywhere else you want by clicking „Ctrl 

+ V‟ key. 

 

(10) Newly Added Disjoined Points Constraint in Sketch mode 

Disjoined Points Constraint had been used in Mesh Sketch mode only. But now, it has 

been newly added in Sketch mode as well. 

Now, you can easily set constraints for disjoined points of sketch curves. 

 

 

(11) Enhanced Selection Option 

Now feature regions can be selected through with Rectangle Section Mode when the 

Visible Only button is toggled off. 
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(12) Newly Added Feedback Tab 

Feedback Tab which allows you to offer or suggest any idea about the product has been 

newly added. 

  

Now your comments will directly be sent to the product support manager and your voice 

will be used for improvement of product functionalities, quality, and stability. 

Make sure that your computer must be connected to the internet in order to use the 

Feedback system. 

 

 

File I/O 

(1) XRL File Version and Newly Added File Format for Massive Point Cloud 

Rapidform XOR‟s file version has been upgraded from version 2.8 to version 3.0. 

Now, model data can be effectively stored in the new file version in order that it can best 

perform in the application. 

Additionally, optimized file format in accordance with new massive point cloud handling 

process has been newly added as new file format called rapidform eXtreme Point Cloud 

(„*.xpc‟).  

If you want to store the in-process model entities, you can effectively use the data by 

storing in the new file format. 
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(2) Import Native CAD File Format 

Now, native file format of major CAD systems such as CATIA V4 („*.model‟) and V5 

(„*.catpart, *.catproduct‟), Pro/ENGINEER („*.prt, *.prt.*, *.asm, *.asm.*‟), UGS NX („*.prt‟), 

SolidWorks („*.sldprt, *.sldasm‟) and AutoCAD (*.dxf‟) can be imported into the 

application. 

 

 

The following table indicates which version of CAD file format Rapidform XOR supports. 

CAD Program File Extension Version Supported Note 

CATIA V4 *.model CATIA 4.1.9 to CATIA 4.2.4  

CATIA V5 *.catpart, *.catproduct CATIA V5 R2 through R20 

Unsupported 

assembly non-

ASCII character 

in the file name 

Pro/ENGINEER *.prt, *.prt.*, *.asm, *.asm.* Pro/E 16 to Wildfire 5  

UGS NX *.prt 
Unigraphics 11 to 18 and 

NX1 to NX6 

 

SolidWorks *.sldprt, *.sldasm SolidWorks 98 to 2010  

 

Note 

You need to install Rapidform Exchange™ License to import these file formats except 

AutoCAD file format. 

 

(3) Export Model Data as CATIA V4 and V5 File Format 

Now, you can export modeling entities such as Body, Curve, Face, and Ref.Geometry to 

the CATIA V4 file format („*.model‟) and the CATIA V5 file format („*.catpart, 

*.catproduct‟). 
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Note 

You need to install Rapidform Exchange™ License to export modeling entities as the 

CATIA V4 and V5 file formats. 

 

(4) Import and Export Model Data as ACIS CAD file format 

Now, you can import and export CAD Models as ACIS CAD („*.sat, *.sab„) file format. 

When you export models as the ACIS CAD file format, the file is formatted as ACIS R7 

version file. 

ACIS Assembly („*.asat, *.asab‟) file format can also be imported into the application. 

 

(5) Added New Scanner File Formats 

Scanner file formats have been newly added in the File Import. 

Newly Added File Formats Property Scanner Vendor Web-Site 

ptg Point Leica http://www.leica-geosystems.com 

rxp, rsp Point or Polygon Riegl http://www.riegl.com 

cl3 Point Topcon http://global.topcon.com 

ptc Point Kubit http://www.kubit.de 

 

Additionally, point cloud can be exported as Leica and Kubit scanner file formats. 

 

 

(6) Set Valid Scanning Range 

When you try to import raw scan data scanned by spherical type of 3D scanner such as 

long range scanner, the application automatically detects that and opens the filtering 

dialog. Now you can easily set a radius of scanning range and filter the outlier of the 

scan data before the data is imported into the application. The outlier of the scan data 

which is farther away than the radius of scanning range defined from the origin of 

scanner coordinates will be automatically filtered. 

http://www.leica-geosystems.com/
http://www.riegl.com/
http://global.topcon.com/
http://www.kubit.de/
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(7) Export Ref.Point 

Now, you can export Ref.Points as „*.txt‟, „*.csv‟ file format as well. The exported position 

information of Ref.Point can be used for evaluating or analyzing. 

  

 

(8) Import Ref.Point 

An option which allows you to import 

position information when Ref.Points 

are created has been newly added as 

one of the methods in the Add Ref.Point 

command.  

Now, you can import position 

information into the application and you can create Ref.Points using the information. 

 

(9) Export Transform Matrix 

Now, after you apply the transform command on a surface/solid body, you can export the 

transformation matrix from the properties of transformation. 
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(10) Import Model Body Only 

If you have a „*.xrl‟ file which you have designed and saved with the entire modeling 

history in Rapidform XOR, you can now import just the modeled bodies only from the 

„*.xrl‟ file without the modeling history. The imported bodies will be registered as an 

„Imported Body‟ in the Feature Tree. 

 

(11) Export Ref.Polyline as IGES, STEP file format 

Now, you can export Ref.Polylines as IGES („*.igs„), STEP („*.stp‟) file format. 

 

(12) Export Curves as DXF file format 

Now, you can export sketch curves (2D / 3D) as AutoCAD DXF („*.dxf) file format. 

The sketch curves will be exported as polylines. 

 

(13) Enhanced Point Stream 

Publish As Point Stream command now 

supports point cloud as well. 

You can publish a point cloud as well as 

a mesh as point stream. 

And when you publish the selected 

entities as point stream, you can also set 

the sampling ratio to the entities. 

Additionally, RPS (Rapidform Point Stream) viewer also has been enhanced to 

effectively see and analyze the model. Shader mode has been newly added in the RPS 

viewer and you can set the display environment with Use Custom Setting option. 
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(14) Enhanced ICF file format 

When you export point clouds as ICF file format, you can export the data with vertex 

normal information as well. You can also import the data including vertex normal 

information into the application.  

Addtionally, if you want to publish huge size point cloud as ICF file format for sharing 

through the Web, now you can adjust the size of data by using sampling ratio as desired. 

 

(15) Enhanced Import Dialog 

Some options in Import dialog has been newly added and rearranged. 

Triangulation Cutoff Angle option which allows you to cut some bad triangulated faces off 

by Angle and Suppress Mesh option which allows you to suppress a mesh as soon as a 

mesh is imported are newly added as importing option. 

 

(16) Enhanced Export Dialog 

Now, you can easily set units in Use Custom Setting when data are exported. 

  

 

(17) Enhanced ASCII Converter 

Comma (,) For Decimal Point option has been newly added in the Convert ASCII dialog. 

If comma is included in the data file, the option will automatically recognize the comma 

as decimal point and allows you to correctly import the data into the application. 

 

liveTransfer™ 

(1) Use Template in Pro/E Wildfire 

When you transfer redesigned models and its entire modeling history to Pro/E Wildfire, 

Rapidform XOR can use user template which has been set in the Pro/E Wildfire. It 

enables you to solve an accuracy problem between Rapidform XOR and Pro/E Wildfire. 
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(2) Newly Supported CAD Program 

Rapidform XOR supports new version of CAD program in the liveTransfer™ 

CAD Program Supported Version Newly Support Version 

CATIA  
CATIA V4 (CATIA 4.1.9) 

CATIA V5 (CATIA V5 R6) 

SolidWorks 

SolidWorks 2006 

SolidWorks 2007 

SolidWorks 2008 

SolidWorks 2009 

SolidWorks 2010 

UGS NX 
UGS NX4 

UGS NX5 

UGS NX6 

UGS NX7 

Pro/E Wildfire 
Pro/E Wildfire 3.0 

Pro/E Wildfire 4.0 
Pro/E Wildfire 5.0 

AutoCAD  

AutoCAD 2007 

AutoCAD 2008 

AutoCAD 2009 

AutoCAD 2010 

AutoCAD 2011 

 

Note 

You need to install Rapidform Exchange™ License to export modeling entities as the 

CATIA V4 and V5 file formats. 

 

(3) Enhanced Feature Regeneration 

When the feature which is created by Cut operation is transfer to the CAD program using 

liveTransfer™, the regeneration process for common cutting surface bodies has been 

greatly enhanced. 

 

(4) Enhanced Transferring Speed 

Transferring speed has been greatly enhanced even though a designed model in 

Rapidform XOR has been generated with complex features such as linear pattern or 

circular pattern. 
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(5) Transfer Sweep, Loft Feature 

Try To Transfer Sweep/Loft As Parametric Feature option has been newly added in the 

liveTransfer(TM) command. When the features which have been designed by using 

Sweep or Loft modeling tools are transferred to the CAD program, this option allows that 

the features can be successfully regenerated as parametric features in CAD program. 

They are no longer dummy features. 

 

 

Scan Tools 

(1) Transform Scan Data 

Transform Scan Data has been newly added as one of the Scan Tools. 

Now, you can transform your scan data as you want it.  

  

 

 And if scan data is far from the origin of 

global coordinates, typically scan data 

generated by long range 3D scanner with 

GPS (global positioning system), it was 

difficult to handle the scan data. 

Now you can easily transform the scan data 

to the origin of global coordinates with 

Transform To Global Origin button no 

matter where the scan data is.  

 

(2) Normal Information Manager 

Normal Information Manager has been newly added as one of the Scan Tools. 

Now, normal information of scan data is automatically and intelligently generated 

considering which type of 3D scanner you have used to get the scan data. 
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If the scan data has been scanned by spherical type of 3D scanner such as long range 

scanner, the normal information of the scan data is generated along the origin of the 

scanner coordinates. 

After the normal information of scan data is generated by using Generate option, you 

can also easily manage the normal information by using the other options such as 

Reverse, Remove, etc. 

 

 

(3) Decimate Meshes 

Decimate Meshes has been newly added as one of the Scan Tools. 

Now, you can apply decimate command to a multiple set of meshes at one time even 

though some meshes are suppressed. 

  

 

(4) Align Between Scan Data 

Refine Alignment option has been newly added 

in the Local Based On Picked Point method. 

After you define corresponding points between 

reference scan data and moving scan data, 

Refine Alignment option will try to best-fit align 

them. Therefore, you can get a better alignment 

result.  

Additionally, you can now align point clouds 

even if they have no normal information. Normal 

information will be automatically generated and then they will be accurately aligned with 

each other. 
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(5) Enhanced Triangulate 

When you apply Spherical 

Projection Method, one of the 

methods in 2D Triangulate, to 

scan data which has been 

scanned by spherical type of 

3D scanner such as long range 

scanner, the application 

automatically detects the origin 

from the geometric information 

of the scan data and uses the information for the triangulation process.  

But, if you need to manually define the origin of scan data, now you can set the origin by 

checking Input Center Manually option. 

When you apply 3D Triangulate to the point 

cloud, you can easily add or edit the distance 

criteria by measuring distance or radius 

between points. 

 

And Sampling Estimate button has been newly 

added as one of More Options in the 2D / 3D 

Triauglate method. If huge size point clouds are 

defined as the target entities, the application 

recommends you appropriate sampling ratio 

which is computable ratio within current available space of your physical memory. You 

can also manually set the radio. If the set sampling ratio is bigger than the 

recommended ratio, warning message is pops up and then you can decide whether you 

apply triangulation to the point cloud or not.  

 

(6) Newly Added Remove Original Data Option in Triangulate and Merge Command  

Remove Original Data option has been newly added as one of the more options in the 

Triangulate and the Merge commands. Now, you can control whether you want to 

remove or keep the original data by using this option. 

 

(7) Enhanced Entity Thumbnail View 

During Mesh Buildup Wizard if you delete some noisy data using Edit Tools, then the 

Entity Thumbnail View is automatically updated. 

And now, if all poly-vertices or poly-faces of one scan entity are deleted, then the entity 

will be removed from the list. 
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(8) Support Suppressed Meshes in Scan Tools 

If you have large size scanned meshes, you usually suppress the meshes for better 

operating in the application. With this new version, some commands such as Transform 

Scan Data, Average Meshes, Boolean, Combine, Merge, and Decimate Meshes have 

been newly added to allow that you can use the suppressed meshes. 

 

Point Cloud Tools 

(1) Free and Easy to Handle Point Clouds 

When you imported a set of point clouds into the application, 

all the point clouds are not registered in the Feature Tree 

and be free from the modeling history. So now, you can 

freely and easily handle the point clouds at one time no 

matter whether they are individually seperated or combined. 

With the previous version, you have to combine the point 

clouds into a single point cloud to edit them at one time.  

But now, you don‟t need to combine the point clouds and you 

can edit them as they are. You can apply sampling, noise 

filtering, smooth, and etc. to the point clouds at one time.  

And moreover, you can much more easily create mesh from point clouds by using 

Construct Mesh command which has been newly added as one of Point Cloud Tools. 

There is no limit to construct mesh even if the point clouds are huge size. You can select 

the entire point clouds or interested partial area of the point clouds and then construct a 

single mesh or several individual meshes from them by using the Construct Mesh 

command. 

   

 

(2) Check Result by Accuracy Analyzer 

Now, you can check the modeling result between point cloud and designed body by 

using Accuracy Analyzer. 
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(3) Enable Convert Entities 

Convert Entities has been newly added as one of the Point Cloud Tools. 

Now, pre-defined surface/solid bodies and Curves can be converted into points in the 

Point Cloud mode. 

The converted entities also can be checked with Accuracy Analyzer(TM) as well. 

  

 

(4) Enhanced Point Smooth 

Now, Point Smooth command can be applied to a set of point clouds considering the 

type of 3D scanner. 

If the point clouds have been scanned by spherical type of 3D scanner such as long 

range scanner, point smoothing is performed along the direction vector to scanner center 

position only for reducing roughness of the point clouds effectively. 

 

(5) Enhanced Offset 

If you have a designed surface or solid body when you offset point cloud with a certain 

distance, you can now use the normal information of the body by checking the Use Body 

Normal option. 

 

Mesh Tools  

(1) Enhanced Fill Hole 

Delete Poly-Face tool has been newly added as 

one of the Editing Tools in Fill Hole command. 

Now, you can select poly-faces and delete the 

bad faces without leaving the command. 

And performance speed of hole filling operation has been greatly improved even though 

the target mesh has color information.  

And Refine Filled Holes option also has been newly added as one of the more options. 

When you fill holes by using Flat method, the Refine Filled Holes allows you to 

automatically adjust the edge length of the fill poly-faces based on the edge length of 

other poly-faces on the boundary.  
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(2) Enhanced Display of Mesh Properties 

Even though mesh is suppressed, now, its properties such as the number of Poly-

Vertices or Faces can be checked in the Properties Panel. 

 

 

(3) Newly Added Mesh Tooltip 

When you enter the Mesh mode by clicking Mesh button in the Tool Palette to edit mesh, 

usually you need to select target mesh before you enter the Mesh mode. 

But, if you do not select any meshes in the Feature Tree or in the Model Tree when you 

enter the Mesh mode, the application will make a blank mesh and you cannot use any 

commands in the mode. If you have some created the other body entities such as 

surface body and solid body, you can use the Convert Body command only in the mode. 

To avoid this mistake, the other Mesh Tooltip, “Insert New Mesh”, has been newly added. 

If your mouse cursor is closed over the Mesh mode to enter the mode without selecting 

any meshes, the Tooltip - “Insert New Mesh” - will be appeared. 
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Texture Tools 

(1) Import Texture 

A limit on size of importable texture image has been removed. You can import a texture 

image no matter how big it is. 

But in case of synthesizing multiple textures (e.g. merge, combine, etc), or whole 

regeneration of texture still has limits. The limits which was previously 2048, has been 

improved to 8192. 

 

(2) Newly Added Copy Texture / Vertex Color 

Copy Texture / Vertex Color command has been newly added as the one of Texture 

Tools. 

If you have similar models and one of the models has texture or vertex color, you can 

copy the texture or vertex color from the reference model and paste it onto the other 

models.  

 

             

< Before Texture Copy >               < After Texture Copy > 
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Ref.Geometry 

(1) Enhanced Ref.Plane  

Constraint option has been newly added in 

the Mirror method. 

Now, when you create a mirror plane, you 

can fix normal direction of mirror plane to 

that of the selected plane using this option. 

 

 

 

(2) Added new method in Ref.Plane 

A new method called as „Extreme‟ has been newly 

added in the Ref.Plane. 

Now, you can place Ref.Plane onto the extreme 

position of target entities along the defined direction. 

 

 

 

 

(3) Added Axis Constraint Option in Ref.Vector 

Constraint option has been newly added in Ref.Vector. 

When you create Ref.Vector by using Revolving or 

Extrusion method, you can set an axis constraint in 

the Constraint Options. 

 

 

 

 

 

Sketch 

2D Sketch 

(1) Align Text 

Now, Text sketches can be generated along the other sketches such as arc, partial 

ellipse, parabola, spline and fitted spline as well. 
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(2) Newly Added Pierce Constraint 

Pierce Constraint has been newly added as one of the constraints. 

Now, you can apply a constraint to a point or node points of 2D sketch on the 

intersection point between the pre-defined 3D sketch and the 2D sketch base plane.  

 

 

(3) Newly Added Slot Sketch 

Slot Sketch has been newly added as one of the 2D Sketch Entities. You easily generate 

a slot sketch on the 2D sketch base plane by definition as well as by fitting on Section 

Polyline.  

 

 

 

 

 

Pierce Constraint   

2D Sketch   

3D Sketch Curve   
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(4) Newly Added Evenly Spaced Points Option 

Evenly Spaced Points option has been newly added in the Rebuild Splines Tool Palette 

and it can be used in 2D Sketch, Mesh Sketch mode. 

It allows you to evenly rearrange the space of node points on the spline curve. 

 

 

(5) Enhanced Sketch Fillet 

Add Dimension option has been newly added in Fillet command. 

When you add a fillet in between sketch entities, you can easily toggle on / off to add 

radial dimension in the fillet command. 

 

(6) Enhanced Convert Entities 

Now, you can convert Ref.Vectors or edges of body which are orthogonal to the sketch 

base plane as a sketch point as well. 

 

(7) Enhanced Sketch Setup 

When the Mesh Sketch is set up with a point cloud, now, points which are within the 

silhouette range of defined base plane can be projected onto the sketch base plane and 

they will be used for sketching profile. You can design sketch entities both on the section 

polyline and on the projected points by snapping and fitting them.  

You can also make them visible or invisible by using the 2D Section Point option in the 

Display Tab and you can also define its color information in the Preferences. 

 

(8) Newly Added Spline Fitting Method 

If Section Polyline had been separated into several segments, several separate spline 

sketches are created by fitting on those respective segments of the Section Polyline. 

But now, a single smooth and continuous spline sketch can be generated even though 

the Section Polyline is separated into several segments. 
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3D Sketch 

(1) Check Result in 3D Sketch Mode with Accuracy Analyzer™ 

Now, Accuracy Analyzer(TM) is performed in the 3D Sketch mode as well. You can 

easily check the deviation between 3D sketch curves and mesh with Accuracy Analyzer 

in the 3D Sketch mode. 

 

(2) Newly Added Option in the Conical method 

An option in which you can define the base position of a 

section cone, has been newly added in the Conical method 

in 3D Sketch Entities > Section command.  

 

 

 

 

 

 

 

 

 

 

 

(3) Enhanced Fit From Points 

Now, you can select edges of feature region and fit these edges to 3D sketch curves 

using Fit From Point command. This command can be used both in the 3D Mesh Sketch 

mode and the 3D Sketch mode. The fitted 3D sketch curves can be used for 

constructing 3D curve network on a mesh. 
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(4) Newly Added Boundary command in 3D Sketch mode 

Boundary command was used in 3D Mesh Sketch mode only. 

But now, you can use Boundary command in 3D Mesh Sketch mode as well as 3D 

Sketch mode. 

 

Surface / Solid 

(1) Attach Deviation Map to Mesh 

After modeling solid / surface bodies from a mesh, now, you can attach the deviation 

result on a mesh which is a tessellated mesh from the modeled bodies. 

The converted mesh with deviation map can be used for RP (Rapid Prototyping) and 

analyzing the prototype model. 

  

 

Note 

Before you attach a deviation result onto the mesh, you need to check the deviation 

result with Accuracy Analyzer(TM). And then you can convert the modeled bodies into a 

tessellated mesh including the deviation color map in the Mesh mode. 

The deviation color map also will be converted into a texture map on the mesh. 

 

(2) Enhanced Loft Surface 

Add Side Curve Influence option has been newly added in 

the Loft Surface command as one of the options. When you 

create a loft surface body connecting the adjacent edges of 

bodies, you can set constraints to the start or end edge of 

loft surface as well as you can consider how the side edges 

of adjacent faces flow by using the Add Side Curve Influence option to get a better result. 
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Without Side Curve Influence 

 

With Side Curve Influence 

 

(3) Enhanced Transform Body 

Now, you can interactively control the scale factor when you scale a surface/solid body 

up or down. And you can also apply transformation matrix file to the target surface/solid 

body. 

 

(4) Changed Option Name in CAD Correct > Refit 

The name of Projection Multiplier option in CAD Correct > Refit command has been 

changed to „Compensation Factor‟ for clear explanation. 

 

(5) Enhanced Variable Fillet Method 

Previously, if you click the Estimate Radius From Mesh button when you apply variable 

fillet to a surface/solid body, only the estimated radius of the target filleting edge had 

been displayed on the Profile View. Now the Variable Fillet Method has been greatly 

enhanced. If you select several connected edges of the surface/solid body and then 

when you click the Estimate Radius From Mesh button, you can check the entire 

estimated radius about the selected edges on the Profile View at the same time. 

And you can also easily remove filleting node points using „Delete‟ key. 
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(6) Changed Option in Mesh Fit 

With previous version, Mesh Fit command had an option called „Create Single Surface‟. 

It allows you to generate a single surface body from selected regions when you create 

fitting surface from a mesh. But you had to check the option whenever you want to 

create a single fitting surface body because the option is by default unchecked. 

Now, it is checked by default. 

 

(7) Enhanced Loft Wizard 

Loft Wizard command has been highly enhanced. When you create a surface body by 

using Loft Wizard, now, all profiles which have same number of control points 

considering the target feature shape will be automatically generated and you can get a 

high quality surface body from the profiles. 

 

 

Measure 

(1) Enhanced Measurement Annotations 

Even though measurement is completely done, now, annotations of measured result will 

not disappear. You can check the measurement result whenever you want to see. 

 

(2) Enhanced Distance Measurement 

Along Faces option has been newly added in the Measure Distance command. 

Now, you can measure linear distance between selected entities as well as distance 

along the faces. 
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(3) Enhanced Section Measurement  

Now, you can directly create Ref.Polyline as well as 

Ref.Plane after you measure section profile by 

selecting the created section profiles. 

 

 

 

 

 

Scanner Direct Control 

(1) Newly Added Scan-To-Reference Alignment Method in liveScan™ 

Alignment method in which you can align scan data to reference body such as surface 

body or solid body by using geometric shape information or specific datums is newly 

added in the liveScan(TM). 

 

(2) Newly Added Probe Method in liveScan™ 

New probe method which compensates probe radius using normal information of target 

surface body is added in the liveScan(TM). 

 

(3) Newly Added Hot Key setting option in liveScan™ 

Hot Key setting option has been newly added in the liveScan(TM). 

Now, you can set hot keys in the Scanner Options or the Probe Options. 

Currently, this option is provided in the specific scanner devices as below. 

 

Distance Along the Faces  

Linear Distance Between Point / Point  

1) [API] IntelliScan/IntelliProbe: scanning with „B‟ button and probing with „A, B, C‟ buttons. 

2) [Leica] T-Scan: probing with „A, B, C‟ buttons. 

3) [Steinbichler] T-Scan: probing with „A, B, C‟ buttons. 
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(4) Kreon Scanner Library 

Now the Kreon liveScan drivers are no longer provided by Rapidform, but the 

"Rapidform plug-in Installer" can be obtained from Kreon. 

 

View 

(1) Enhanced View Clip 

View Clip has been enhanced. If you have clipped the model, now you can make section 

profiles which are formed until the boundary of the clipped area of model. 

You can use this functionality in Measure > Section, 3D Sketch Entities > Section, and 

Mesh Sketch Setup.   

  

If you select poly-vertices from point cloud in Point 

Cloud mode, you can easily set view clipping 

range from the selected poly-vertices by choosing 

the Set View Clip From Selection option in the 

pop-up menu and you can also edit the defined 

view clip by choosing the Edit View Clip option.   

You can set Hot Keys for controlling the scan job 
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Add-Ins 

(1) Changed Operation Method 

Now, Delete Poly-Faces allows you to delete poly-faces by Delete key as well. 

 

(2) Newly Integrated and Moved Add-Ins 

Some Add-Ins has been newly integrated and moved to Scan Tools. 

 

 

 

 

 

 

 

 

 

(3) Enhanced Register Target 

Set Target Manually option is newly added as one of the 

registration methods in the Register Target command. 

If you have a set of scan data which is scanned with 

reference target balls, you can align a set of scan data by 

using automatic target ball detection method as well as you 

can align a set of scan data by manually selecting reference 

target balls. 

 

 

 

 

 

 

 

 

(4) IGES Point Importer 

An add-in function that imports points from IGES files as 

point cloud has been newly added as one of Add-Ins. 

This add-in performs faster than the general import 

function in case of IGES points. 

 

Import Large Data: Integrated to Insert > Import  

Global Register: Integrated to Scan Tools > Align Between Scan Data  

2D Triangulate, 3D Triangulate: Integrated to Scan Tools > Triangulate  

Triangulate/Merge Large Data: Integrated to Scan Tools > Triangulate, Merge  

Surface Merge, Volume Merge: Integrated to Scan Tools > Merge 

Combine: Moved to Scan Tools > Combine  

Find Scan Direction: Integrated to Scan Tools > Triangulate as one of the sub options. 

Generate Vertex Normal, Reverse Normal: Integrated to Scan Tools > Normal Information Manager 
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3. List of Fixed Bugs 

General 

1) Disappearing volume name in Property  

If you clicked the Calc. button to measure entity‟s volume in the Properties panel, the 

volume name disappeared. This bug has now been fixed. 

 

2) Unable to connect file accessing  

When you imported a scan data and executed the New command to clear all data, the 

application still made a connection with the folder of previously imported file. Therefore you 

could not delete the folder and change its name. This bug has now been fixed. 

 

3) Repair broken license 

If the borrowed license was broken, License Utility could not repair it. This bug has now 

been fixed. 

 

4) Floating license on Windows XP 64-bit     

The floating license did not work on Windows XP 64-bit environment. This bug has now 

been fixed. 

 

5) The Enter key on License Utility 

If you press the Enter key to move to the next procedure in License Utility, it was 

terminated. This bug has now been fixed. 

 

6) Registry Clean in License Utility  

If you applied Registry Clean, all folders named with prefix “Rapidform” in the My 

Document were removed. This bug has now been fixed. 

 

7) Multiple scan to CAD alignment  

If there were multiple scan data and apply Quick Alignment with the Run Best Fit 

Alignment option, the selection for Moving Mesh was cleared. This bug has now been 

fixed. 



 

 Rapidform XOR3 – What’s New  67 

File I/O 

1) Importing huge .fws and .fls files 

If you tried huge .fws and .fls files that size is more than 3 GB (100 million points), it took 

long time or crashed. This bug has now been fixed. 

 

2) Missed file formats from All Supported Files 

The .ptx, .fls and .fws files were not seen on the Import dialog box when you choose All 

Supported Files. This bug has now been fixed. 

 

Point Cloud 

1) Decimation with color preservation 

If a textured mesh was decimated, the texture quality was compromised. This bug has now 

been fixed. 

 

Mesh 

1) Mesh Buildup Wizard with texture 

If you ran Mesh Buildup Wizard with textured scan data, the application was very slow 

and it might look freeze. This bug has now been fixed. 

 

2) Mesh Buildup Wizard with wrong normal information in scan data 

If scan data had wrong normal information and fixed with manual command during Mesh 

Buildup Wizard process, the result of registered mesh was slightly slipped. This bug has 

now been fixed. 

 

3) Fill holes with textured mesh 

If you tried filling holes with a textured mesh, it took much time. This bug has now been 

fixed. 
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4) Split a mesh without a plane 

If you tried to split a mesh with the By User Defined Plane option but you clicked the Next 

button without selecting the plane, the application might crash. This bug has now been 

fixed. 

 

5) Mesh quality from Mesh Buildup Wizard  

The result mesh from Mesh Buildup Wizard generated more bad poly-faces than the 

previous version‟s result. This bug has now been fixed. 

 

6) Boolean meshes  

When you performed boolean operation with meshes that contain very short length poly-

edges such as less than 0.01 mm, the application might crash. This bug has now been 

fixed. 

 

Sketch 

1) Split curve 

If you selected multiple curves and tried to split curves, it incorrectly worked or might crash. 

This bug has now been fixed. 

 

2) Section of 3D Sketch with the Conical method 

If the base plane was perpendicular to the axis of the Radial, Cylindrical and Conical 

method in the Section command on 64-bit edition, the application might crash. This bug 

has now been fixed. 

 

3) Afterimage in Mesh Sketch Setup 

If you set a base plane and clear it in Mesh Sketch Setup, the afterimage of sectional 

poly-lines was shown. This bug has now been fixed. 

 

4) Cylindrical and Conical sectioning  

If you turned off the Equal Spacing option at Radial method and changed method to 

Cylindrical or Conical, the Interval Angle option was displayed and the Total Angle 

option was not displayed. This bug has now been fixed. 



 

 Rapidform XOR3 – What’s New  69 

5) The wrong draft angle in Mesh Sketch Setup 

Sometimes the draft angle was estimated to the negative direction in Mesh Sketch Setup. 

This bug has now been fixed. 

 

6) Cannot copy and paste construction geometries 

You could not copy and paste construction geometries to another sketch plane. This bug 

has now been fixed. 

 

7) Unsavable settings in Spline  

The parameters under Fit Spline in the Spline command were not preserved. This bug 

has now been fixed. 

 

8) Preview of 3D curve  

If the offset value is 0 while generating a 3D curve from a mesh boundary, the preview 

curve changed whenever you checked on and off the Offset option. This bug has now 

been fixed. 

 

9) Merge curves 

The result shape of the Merge command was different as your selection order of curves. 

This bug has now been fixed. 

 

Ref. Geometry 

1) Ref. Plan on the curve node 

If you used the Definition method when creating a perpendicular ref. plane to a curve, it 

was not created on the node point of the curve. This bug has now been fixed. 

 

2) Revolution axis from tessellated CAD 

The application could not find the revolution axis from the perfectly symmetry mesh such 

as the tessellated mesh from CAD. This bug has now been fixed. 
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Solid / Surface / Feature 

1) Region selection in Mesh Fit 

Sometimes you could not select multiple regions during Mesh Fit. This bug has now been 

fixed. 

 

2) Selection problem in Surface Loft 

If you turned off Preview and tried to select multiple edges to make a composite curve 

under Surface Loft command, some edges were not selected. This bug has now been 

fixed. 

 

3) Mesh Fit on complex boundaries 

Sometimes Mesh Fit surfaces were not generated especially on complex mesh 

boundaries. This bug has now been fixed. 

 

liveTransfer™  

1) liveTransfer to Pro/E problem with multi-byte character set entities  

If entities are named with multi-byte character set (MBCS) or some symbols, they were not 

transferred to Pro/E. This bug has now been fixed. 

 

2) Extrude to the same surfaces in both directions   

If a single surface is used for the Up To Surface option in Extrude with the Both 

Direction option, it made an error when you exported it using liveTransfer To 

SolidWorks. Now it is sent as a dummy entity.  

 

3) Wrong error message in Error List    

If you extruded a sketch with the Blind and Draft option, a wrong error message appeared 

regardless of the Blind option while you check CAD compatibility to Pro/E Wildfire in the 

Error List panel. This bug has now been fixed.  

 

4) Loading UGS NX    

If your system used multi-byte character set account name, liveTransfer could not start 

UGS NX. This bug has now been fixed.  
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5) liveTransfer a sketch to SolidWorks 

After liveTransfer to SolidWorks, sketch entities might be located at a wrong position and 

be flipped. This bug has now been fixed.  

 

Scanner Direct Control 

1) Texture problem with Konica Minolta data 

When scanning data created by using VIVID Direct Control or importing .vvd format in the 

Konica Minolta VIVID panel, the texture image was slightly offset from its original position. 

This bug has now been fixed. 

 

2) Unable to save/Import raw data file  

The application could not import or export raw data when the file path includes multi-byte 

character set under the liveScan command. This bug has now been fixed. 

 

3) Unable to connect Kreon device  

It was not able to connect Kreon device in the liveScan command. This bug has now been 

fixed. 
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